eg-blog

Feed Rss

Subsonic 4.7-029 Synology Package

11.22.2012, Allgemein, Download / Release Notes, Subsonic on Synology DS, by .

 

Errors errors errors…fixes fixes fixes (hopefully)

Many of you had troubles starting my last build of the Subsonic package. I changed the detection method of the PID. Now it will most certainly run. But As I din’t have any errors I can’t really guarantee a smooth operation because there was no real bug fixing possible to me…

 

 

The rest is equal to the previous package.

Download from Dropbox folder:

https://www.dropbox.com/sh/vd06e2fn2157gh0/kE6FO5J1cD

 

Update button in the Package Center will appear soon.

 

 

 

 

 

 

 

25 Kommentare zu Subsonic 4.7-029 Synology Package

  1. Eric,

    I’ve uninstall subsonic package from dsm package manager, but now when I try to re-install it I have error message : Cannot start Subsonic during install

    Subsonic package seems to be installed correctly cause I can view it in installed package but when I tried to launch Subsonic from here I have the same issue

    When I go to users management interface I don’t see Subsonic daemon user and when I go in ssh in /volumeX/@appstore I didn’t find subsonic folder

    The only log file I found is subsonic_package.log but there is no error

    Have you a solution ?

    Antworten
    • 2013-02-17 at 17:38 Julian

      Hey there, had exactly the same problem. I’ve found a solution.

      - uninstall subsonic
      - reinstall java (optional: I did. have java7 installed)
      - ssh in your DS: look for Subsonic-folders (Subsonic, Mini-Sub, etc.) at

      /usr/syno/synoman/webman/3rdparty/

      and

      /volume1/@appstore/

      - delete both (be sure to have a backup), like so:

      rm -r /usr/syno/synoman/webman/3rdparty/Subsonic

      - check $JAVA_HOME if you upgrade from java6 to java7 and change it (or reboot)

      export JAVA_HOME=/volume1/@appstore/java7/jre

      - reinstall Subsonic package
      choose your backup to be restored and select everything you need

      - installation may take some time

      - wait 1-2min until Subsonic is started

      - have fun again!

      Cheers, Julian

      btw: Thanks for the awesome Package! :)

      Antworten
  2. I’m thinking the problem is due to the last version of DSM 4.1-2657 cause I have tried to uninstall/reinstall another package and same issue (service cannot be launched and no dameon user)

    It’s like daemon user couldn’t be created (I can’t see daemon user in users management console) but there is no error :
    DiskStation> cat subsonic_package.log
    23.11.12_23:22:36: create subsonic daemon user
    23.11.12_23:22:36: download and install MashupMod
    23.11.12_23:25:44: downloaded MashupMod from http://uploaded.net/file/6kzehtl6/from/zryfjb
    23.11.12_23:25:45: extracted MashupMod
    23.11.12_23:25:45: deleted downloaded files
    23.11.12_23:25:45: deleted original subsonic.sh file
    23.11.12_23:25:45: now using edited subsonic.sh file for Synology
    23.11.12_23:26:15: downloaded ffmpeg files from http://eg-blog.de/download/serviio-native-ppc.tgz
    23.11.12_23:26:15: created transcode directory
    23.11.12_23:26:15: created lib directory
    23.11.12_23:26:16: copied ffmpeg file and libraries
    23.11.12_23:26:16: start Subsonic for first initialisation
    23.11.12_23:26:21: looking for PID
    23.11.12_23:26:21: Error: Can not start Subsonic during install

    Antworten
  3. 2012-11-24 at 04:46 Seth Feinberg

    Just installed the new package in the package center and everything is working smooth as ever. Thanks!!!!

    Antworten
  4. Everything is working for me too.
    I have uninstall/reinstall java package and now all is working again.

    Antworten
  5. I’m sorry but transcoding doesn’t work for me on ds213+, like with the previous version … :(

    Antworten
  6. I have changed flv/h264 transcoding string with this one :
    ffmpeg -ss %o -i %s -async 1 -b %bk -s %wx%h -ar 44100 -ac 2 -v 0 -f flv -

    It seems to be working now.

    Antworten
  7. 2012-11-29 at 23:59 Tigroz

    Hi, is this package solving the problem that Synology cannot go on sleep mode? Please help, thanks.

    Antworten
  8. 2012-12-02 at 14:47 Michael

    Hi, i have installed the 4.7 29 on my 2411+ without errors. But subsonic doesn`t work. After stop and start in the package manager subsonic works until the next reboot. Any ideas ?

    Antworten
  9. 2012-12-08 at 12:10 Tigroz

    I have encountered 2 problems: NAS does not go anymore on sleep mode, and Subsonic does not transcode my FLAC files, any help?

    Thanks

    Antworten
  10. Hi Michael and Tigroz
    I am aware of the sleep mode problem it has occurred since the first version I made and never been solved.
    The problem is that Subsonic accesses the disk from time to time which is not documented anywhere.
    I am working on it…
    this topic from the serviio Forum looks promising http://forum.serviio.org/viewtopic.php?f=5&t=6878&start=20

    Antworten
  11. Hi Eric,

    Is this normal if I have “Video not found or Access denied” when I set : “-vcodec” or “-acodec” or “-preset” settings (transcoding conf: ffmpeg -ss %o -i %s -async 1 -b %bk -s %wx%h -ar 44100 -ac 2 -v 0 -f flv -vcodec libx264 -preset superfast -threads 0 -)

    That work without those settings but video is buffering every 10 secondes… (transcoding conf: ffmpeg -ss %o -i %s -async 1 -b %bk -s %wx%h -ar 44100 -ac 2 -v 0 -f flv -)

    Have you a solution ?

    My DiskStation is a DS213+.

    Antworten
  12. 2012-12-15 at 01:08 Tigroz

    Thanks Eric, please let us know when sleep mode problem is solved, thanks. 2nd problem was on transcoding, Subsonic does not transcode my FLAC files, any help?

    Antworten
  13. hi,
    I also can’t play any video files in Subsonic.
    I get a ‘Video not found or access denied:/stream?id=4243&….’ error message in the web player.

    When I check the logs I find

    [12/23/12 5:20:39 PM CET] WARN StreamController Unknown duration for Video. Unable to estimate transcoded size.

    [12/23/12 5:20:39 PM CET] INFO PlayQueueInputStream admin listening to “Serien/Video.avi”

    [12/23/12 5:20:40 PM CET] DEBUG TranscodeInputStream Starting transcoder: [/usr/syno/synoman/webman/3rdparty/Subsonic/transcode/ffmpeg] [-ss] [0] [-i] [/volume1/video/Serien/Video.avi] [-async] [1] [-b] [1000k] [-s] [480x360] [-ar] [44100] [-ac] [2] [-v] [0] [-f] [flv] [-vcodec] [libx264] [-preset] [superfast] [-threads] [0] [-]

    [12/23/12 5:20:40 PM CET] DEBUG InputStreamReaderThread (/usr/syno/synoman/webman/3rdparty/Subsonic/transcode/ffmpeg) /usr/syno/synoman/webman/3rdparty/Subsonic/transcode/ffmpeg: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

    The last entry is interesting I think… ffmpeg is looking for libz.so.1?

    /lib/libz.so.1 exists but there is no libz.so.1 in /usr/syno/synoman/webman/3rdparty/Subsonic/lib

    I already copied it in there but no success…
    I’m not a very experienced Linux user … so any ideas?
    My DS is a 712+ (x86)

    Antworten
  14. 2013-01-04 at 00:32 Russell

    I have tried and succeeded at installing4.7-029 on my DS412+ which is intel based

    I installed java ejre-1_6_0_38-fcs-b05-linux-i586-headless-13_nov_2012
    (which is version 6 update 38 x86 Linux Small Footprint – Headless)

    in public and your java se embeded

    once running if i go to port 4040 i get a that there is nothing there to connect to.

    i am running dsm 4.1-2668

    Any reason this shouldn’t work?

    Antworten
  15. Hi Eric,

    I have installed this version but I can’t connect any external apps. They all fail: MiniSub, Windows Phone app. I have licensed Subsonic and can verify that the server registers ok via subsonic.org. I have tried manual port forwarding and uPnP but they both work fine enough for me to log into the normal Subsonic Web UI remotely. I have verified that I can query the REST API without issue (http://www.subsonic.org/pages/api.jsp) so the licence is definitely ok.

    When I try to connect MiniSub I get the error “Bad Server”. The Windows Phone app returns this after a connection test “Connection failed: The remote server returned an error: NotFound.”

    I’ve tried the connection string in the formats:
    myserver.subsonic.org
    myserver.subsonic.org:4040
    http://myserver.subsonic.org:4040/subsonic (which MiniSub seems to suggest)
    https://myserver.subsonic.org:4041
    …and just about every other combination.

    It used to work with an older version of the package so do you know why this is not working now? Do you use it with 3rd party clients?

    Antworten
  16. I also tried the Windows Java app SubClient and that didn’t connect either. Cannot connect to the server. Make sure all parameters are correct. As I said – these same credentials work fine for REST API queries.

    Antworten
  17. 4.7-30 is on the way, I have not encountered any connection errors so far
    iSub and miniSub are working well…

    Antworten
  18. I have uploaded the latest build to my beta folder, feel free to test. If you do so please leave me a message containing your System details and errors..

    https://www.dropbox.com/sh/y9lcl2xsznvve80/31mcnc5gpE

    Antworten
  19. Hi Eric,

    I tried to install your latest build 4.7-30 on my DS213+ with DSM 4.2 beta (3161) and I get cheksum error from subsonic_package.log file :

    30.01.13_22:00:27: create subsonic daemon user
    30.01.13_22:00:27: download and install MashupMod
    30.01.13_22:10:47: downloaded MashupMod from http://uploaded.net/file/6kzehtl6/from/zryfjb
    30.01.13_22:10:47: SHA256 checksum failed for MashupMod.zip

    Antworten
  20. I can confirm the FLAC transcoding not working on 4.7-029. Unfortunately, I couldn’t get version 4.7-030 to work… With FLAC transcoding I get the following error message:
    “Subsonic/transcode/ffmpeg: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory”

    It seems like the ffmpeg library is (partially) missing?

    Thanks.

    Antworten
  21. Hi Everybody,

    I wanted to update my susbsonic to 4.7 and figured I might as well update my DSM and java as well. I got myself in some trouble though.

    After updating to DSM 4.1-2668 on mu DS211j I’m not able to install Java and Subsonic.
    After updating DSM, I tried to do a fresh java install. Although the links are correct in the install files Package Center says that there was a problem downloading the java-native-armv5tel.tgz file. The subsonic package has the same problem, but than with the subsonic 4.7 standalone install file.

    Manually installing the pacakges doesn’t work either. Placing all the files in my public share folder doesn’t solve the problem. When i place the wrong java install in my public folder package center does mention that it was expecting a other file. Placing the right file in the public folder makes this message dissapear, but then there is the downloading problem. So it seems to find my public folder, but it doesn’t install the files that are in there.

    Does anyone knows what’s wrong? Any help is appreciated!

    After using subsonic for years now, I miss it everyday. I’m not looking forward to installing it manually through ssh again.

    Antworten
  22. Hi Julian,

    Thank you for your reply and tips! It is indeed a great package.

    I had the same problem installing java as well, but i fixed that by installing it through ssh. I will follow your suggestions this weekend and let you know if it worked out. Thanx again!

    Antworten
  23. Thnx gor the package and thank you Julian for the tips!

    I solved my problem by installing java through ssh and installig subsonic through ssh. However With subsonic 4.7 artwork is only displayed when there is a music file in the folder. Since I have my files managed like cd’s I have every disc in a single folder. With 2 cd sets subsonic 4.7 doesn’t display the artwork. Since I use subsonic only for music and 4.6 was working perfect for me I decided to downgrade to 4.6 but wanted to use the package installer for this.

    As Julian tipped, I uninstalled java manually through ssh and cleaned some folders. After that I could use the package installer again for java and subsonic 4.6. So thnx everybody. Gonna enjoy my music now.

    Kind regards,

    Lucas

    Antworten
  24. Right away I am ready to do my breakfast, when having my breakfast coming over again to read additional news.

    Antworten

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>